]> iEval git - rateit.git/blobdiff - debian/patches/fix-makefile.patch
Add debian/ directory
[rateit.git] / debian / patches / fix-makefile.patch
diff --git a/debian/patches/fix-makefile.patch b/debian/patches/fix-makefile.patch
new file mode 100644 (file)
index 0000000..08bfd5b
--- /dev/null
@@ -0,0 +1,13 @@
+Description: Fix the Makefile
+ This patch adds hardening flags, makes the clean target work when there is nothing to clean and only links against needed libraries.
+Forwarded: no
+Author: Marius Gavrilescu <marius@ieval.ro>
+Last-Update: 2013-09-04
+--- a/Makefile
++++ b/Makefile
+@@ -4,4 +4,4 @@
+       cat rateit.glade | perl -e 'print "static unsigned char rateit_glade[]=";while(<>){s/"/\\"/g; s/^/"/; s/$$/\\n"/; print}print ";\n"' > rateit_glade.h
+ rateit: rateit.c rateit_glade.h
+-      gcc -g -O2 rateit.c -o rateit `pkg-config --cflags --libs libglade-2.0` -export-dynamic
++      gcc $(shell pkg-config --cflags libglade-2.0) $(CFLAGS) $(CPPFLAGS) rateit.c -o rateit $(LDFLAGS) -lglade-2.0 -lgtk-x11-2.0 -lxml2 -lgobject-2.0 -lglib-2.0 -export-dynamic
This page took 0.017755 seconds and 4 git commands to generate.