]> iEval git - xfishtank.git/blobdiff - debian/rules
Imported Debian patch 2.3-1
[xfishtank.git] / debian / rules
diff --git a/debian/rules b/debian/rules
new file mode 100755 (executable)
index 0000000..5148da0
--- /dev/null
@@ -0,0 +1,50 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
+
+build-stamp:
+       dh_testdir
+       xmkmf -a
+       $(MAKE)
+       touch build-stamp
+
+clean:
+       dh_testdir
+       dh_testroot
+       rm -f build-stamp
+       [ ! -f Makefile ] || $(MAKE) clean
+       dh_clean Makefile
+
+# Build architecture-independent files here.
+binary-indep: build
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build
+       dh_testdir
+       dh_testroot
+       dh_clean
+       dh_installdirs
+       $(MAKE) DESTDIR=debian/tmp install
+       dh_install
+       dh_installdocs README*
+       dh_installmenu
+       dh_installman xfishtank.1x
+       dh_installchangelogs
+       dh_strip
+       dh_compress
+       dh_fixperms
+       dh_installdeb
+       dh_shlibdeps
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary
This page took 0.020513 seconds and 4 git commands to generate.