Use proper hardening options
[fdkaac.git] / debian / rules
index 9fc0ce34f273e9f75b77a3c9728b111cca9a58ab..364bc4c811516caa5a7bae8b05dca65b0fffa901 100755 (executable)
@@ -1,13 +1,11 @@
 #!/usr/bin/make -f
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
 DPKG_EXPORT_BUILDFLAGS = 1
 include /usr/share/dpkg/default.mk
 
 %:
-       dh $@
+       dh $@ --with autoreconf
 
-override_dh_auto_configure:
-       autoreconf -i
-       dh_auto_configure
-
-override_dh_clean:
-       dh_clean Makefile.in aclocal.m4 compile config.guess config.h.in config.sub configure depcomp install-sh missing
+override_dh_auto_build:
+       pandoc -s -f markdown -t man README >fdkaac.1
+       dh_auto_build
This page took 0.009656 seconds and 4 git commands to generate.