]> iEval git - filters.git/blobdiff - debian/rules
releasing version 2.35
[filters.git] / debian / rules
index 9544c4e1e7f8e58c258027e23d2e4d364c912eb0..2260c614e0555740691969b4fbe90712f808645e 100755 (executable)
@@ -1,11 +1,4 @@
 #!/usr/bin/make -f
-# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-# This is the debhelper compatibility version to use.
-export DH_COMPAT=2
 
 build: build-stamp
 build-stamp:
@@ -21,24 +14,15 @@ clean:
        -$(MAKE) -i clean
        dh_clean
 
-# Build architecture-independent files here.
 binary-indep: build
-# We have nothing to do by default.
 
-# Build architecture-dependent files here.
 binary-arch: build
        dh_testdir
        dh_testroot
        dh_clean -k
        dh_installdirs
        $(MAKE) PREFIX=debian/filters install
-       dh_installdocs README SAMPLES
-       dh_installexamples
-       dh_installmenu
-#      dh_installinit
-       dh_installcron
-       dh_installmanpages
-#      dh_undocumented
+       dh_installdocs README SAMPLES ky00te.dir/README.ky00te
        dh_installchangelogs
        dh_strip
        dh_compress
@@ -46,9 +30,20 @@ binary-arch: build
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol
-#      dh_makeshlibs
        dh_md5sums
        dh_builddeb
 
+VERSION=$(shell expr "`dpkg-parsechangelog 2>/dev/null |grep Version:`" : '.*Version: \(.*\)')
+
+# Update the web page. Not intended for use by anyone except the
+# author.
+DIR=/home/web/kitenet.net/programs/filters
+installhook:
+       cp debian/changelog $(DIR)/CHANGES
+       cp TODO $(DIR)/TODO
+       echo -n $(VERSION) > $(DIR)/LATEST-VERSION-IS
+       rm -f $(DIR)/*.tar.gz
+       ln -s /home/joey/lib/debian/unstable/filters_$(VERSION).tar.gz $(DIR)/filters-$(VERSION).tar.gz
+
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary
This page took 0.022955 seconds and 4 git commands to generate.