Use proper hardening options
[filters.git] / debian / rules
index 9544c4e1e7f8e58c258027e23d2e4d364c912eb0..a726a69fb789659b862ae6af14bd6ee152407b30 100755 (executable)
@@ -1,54 +1,4 @@
 #!/usr/bin/make -f
-# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-# This is the debhelper compatibility version to use.
-export DH_COMPAT=2
-
-build: build-stamp
-build-stamp:
-       dh_testdir
-       $(MAKE)
-       $(MAKE) samples
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp
-       -$(MAKE) -i clean
-       dh_clean
-
-# Build architecture-independent files here.
-binary-indep: build
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs
-       $(MAKE) PREFIX=debian/filters install
-       dh_installdocs README SAMPLES
-       dh_installexamples
-       dh_installmenu
-#      dh_installinit
-       dh_installcron
-       dh_installmanpages
-#      dh_undocumented
-       dh_installchangelogs
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-#      dh_makeshlibs
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+%:
+       dh $@
This page took 0.010235 seconds and 4 git commands to generate.