Use proper hardening options
[filters.git] / debian / rules
index cf979f2c9a642035410a108e40264e7aca5e23c1..a726a69fb789659b862ae6af14bd6ee152407b30 100755 (executable)
@@ -1,41 +1,4 @@
 #!/usr/bin/make -f
-
-build: build-stamp
-build-stamp:
-       dh_testdir
-       $(MAKE)
-       $(MAKE) samples
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp
-       $(MAKE) -i clean
-       dh_clean
-
-binary-indep: build
-
-binary-arch: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs
-       $(MAKE) PREFIX=debian/filters install
-       dh_installdocs README SAMPLES ky00te.dir/README.ky00te
-       dh_installchangelogs
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-# Not intended for use by anyone except the author.
-announcedir:
-       @echo ${HOME}/src/joeywiki/code/filters/news
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+%:
+       dh $@
This page took 0.01031 seconds and 4 git commands to generate.