Use proper hardening options
[filters.git] / debian / rules
index d07e583e7979aeeef70312cdc4b1b798666a2e2f..a726a69fb789659b862ae6af14bd6ee152407b30 100755 (executable)
@@ -1,48 +1,4 @@
 #!/usr/bin/make -f
-
-build: build-stamp
-build-stamp:
-       dh_testdir
-       $(MAKE)
-       $(MAKE) samples
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp
-       -$(MAKE) -i clean
-       dh_clean
-
-binary-indep: build
-
-binary-arch: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs
-       $(MAKE) PREFIX=debian/filters install
-       dh_installdocs README SAMPLES ky00te.dir/README.ky00te
-       dh_installchangelogs
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-VERSION=$(shell expr "`dpkg-parsechangelog 2>/dev/null |grep Version:`" : '.*Version: \(.*\)')
-
-# Update the web page. Not intended for use by anyone except the
-# author.
-DIR=/home/web/kitenet.net/programs/filters
-installhook:
-       cp debian/changelog $(DIR)/CHANGES
-       echo -n $(VERSION) > $(DIR)/LATEST-VERSION-IS
-       rm -f $(DIR)/*.tar.gz
-       ln -s /home/joey/lib/debian/unstable/filters_$(VERSION).tar.gz $(DIR)/filters-$(VERSION).tar.gz
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+%:
+       dh $@
This page took 0.009675 seconds and 4 git commands to generate.