]> iEval git - filters.git/blobdiff - debian/rules
releasing version 2.40
[filters.git] / debian / rules
index 9e8bbc80a913965c9855247f545be8d0bb788c59..cf979f2c9a642035410a108e40264e7aca5e23c1 100755 (executable)
@@ -1,11 +1,4 @@
 #!/usr/bin/make -f
-# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-# This is the debhelper compatibility version to use.
-export DH_COMPAT=3
 
 build: build-stamp
 build-stamp:
@@ -18,14 +11,11 @@ clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp
-       -$(MAKE) -i clean
+       $(MAKE) -i clean
        dh_clean
 
-# Build architecture-independent files here.
 binary-indep: build
-# We have nothing to do by default.
 
-# Build architecture-dependent files here.
 binary-arch: build
        dh_testdir
        dh_testroot
@@ -33,10 +23,6 @@ binary-arch: build
        dh_installdirs
        $(MAKE) PREFIX=debian/filters install
        dh_installdocs README SAMPLES ky00te.dir/README.ky00te
-       dh_installexamples
-       dh_installmenu
-       dh_installcron
-       dh_installmanpages
        dh_installchangelogs
        dh_strip
        dh_compress
@@ -47,5 +33,9 @@ binary-arch: build
        dh_md5sums
        dh_builddeb
 
+# Not intended for use by anyone except the author.
+announcedir:
+       @echo ${HOME}/src/joeywiki/code/filters/news
+
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary
This page took 0.020744 seconds and 4 git commands to generate.