]> iEval git - filters.git/blobdiff - debian/rules
no todo
[filters.git] / debian / rules
index 78fd8eb6e518e8450bfd447d0fb901ff335429ba..d07e583e7979aeeef70312cdc4b1b798666a2e2f 100755 (executable)
@@ -1,8 +1,4 @@
 #!/usr/bin/make -f
-# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
 
 build: build-stamp
 build-stamp:
@@ -18,36 +14,35 @@ clean:
        -$(MAKE) -i clean
        dh_clean
 
-# Build architecture-independent files here.
 binary-indep: build
-# We have nothing to do by default.
 
-# Build architecture-dependent files here.
 binary-arch: build
-#      dh_testversion
        dh_testdir
        dh_testroot
        dh_clean -k
        dh_installdirs
-       $(MAKE) PREFIX=debian/tmp install
-       dh_installdocs README SAMPLES
-       dh_installexamples
-       dh_installmenu
-#      dh_installinit
-       dh_installcron
-       dh_installmanpages
-#      dh_undocumented
+       $(MAKE) PREFIX=debian/filters install
+       dh_installdocs README SAMPLES ky00te.dir/README.ky00te
        dh_installchangelogs
        dh_strip
        dh_compress
        dh_fixperms
-       dh_suidregister
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol
-#      dh_makeshlibs
        dh_md5sums
        dh_builddeb
 
+VERSION=$(shell expr "`dpkg-parsechangelog 2>/dev/null |grep Version:`" : '.*Version: \(.*\)')
+
+# Update the web page. Not intended for use by anyone except the
+# author.
+DIR=/home/web/kitenet.net/programs/filters
+installhook:
+       cp debian/changelog $(DIR)/CHANGES
+       echo -n $(VERSION) > $(DIR)/LATEST-VERSION-IS
+       rm -f $(DIR)/*.tar.gz
+       ln -s /home/joey/lib/debian/unstable/filters_$(VERSION).tar.gz $(DIR)/filters-$(VERSION).tar.gz
+
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary
This page took 0.022331 seconds and 4 git commands to generate.