Do not link against libXext and libm
[xfishtank.git] / debian / rules
index 5148da0019444e402121ec194dc02288e35c6301..a0b425a93cb56e0d0dec8529c7eb764fbda7d2f7 100755 (executable)
@@ -1,50 +1,8 @@
 #!/usr/bin/make -f
-# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-build: build-arch build-indep
-build-arch: build-stamp
-build-indep: build-stamp
-
-build-stamp:
-       dh_testdir
+%:
+       dh $@
+override_dh_auto_build:
        xmkmf -a
-       $(MAKE)
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp
-       [ ! -f Makefile ] || $(MAKE) clean
-       dh_clean Makefile
-
-# Build architecture-independent files here.
-binary-indep: build
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build
-       dh_testdir
-       dh_testroot
-       dh_clean
-       dh_installdirs
-       $(MAKE) DESTDIR=debian/tmp install
-       dh_install
-       dh_installdocs README*
-       dh_installmenu
-       dh_installman xfishtank.1x
-       dh_installchangelogs
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary
+       dh_auto_build -- CCOPTIONS="$(shell dpkg-buildflags --get CFLAGS)" EXTRA_LOAD_FLAGS="$(shell dpkg-buildflags --get LDFLAGS)" SYS_LIBRARIES= EXTENSIONLIB=
+override_dh_auto_install:
+       dh_auto_install -- BINDIR=/usr/games
This page took 0.010325 seconds and 4 git commands to generate.